提问



我想使用Android API 19.我在project.properties文件中更改了 target=android-19 。在AndroidManifest.xml中。我有这个 :


<uses-sdk android:minSdkVersion="10" android:targetSdkVersion="19" />


但在项目属性中我有这个:



如何将API级别更改为19以消除标题中的错误。
谢谢。

最佳参考



  1. 转到Windows - > Android SDK Manager
    安装所需的Android API级别,在本例中为19。

  2. 完成安装后,转到Window - > Preference - > Android。
    您应该获得可用目标的列表。单击应用,然后单击确定。

  3. 现在右键单击您的项目,转到属性。点击Android。选择您想要的目标。


其它参考1



  1. 右键点击您的项目

  2. 转到属性 - >单击Android(左窗格)

  3. 选择您的项目目标版本。

  4. 重启Eclipse

  5. 清理项目(单击项目菜单 - >清除)

  6. 现在运行该项目。


其它参考2


窗口 - >首选项 - > Android。您应该获得可用目标的列表。单击应用,然后单击确定。


现在右键单击您的项目,转到属性。点击Android。选择您想要的目标。

其它参考3


检查并将SDK API20添加到项目,清理和构建项目。


您可以忽略此警告


编辑:


如果您可以使用19,则必须通过Android SDK安装API 19

其它参考4


Window-> Preferences-> Android并在打开Android SDK Manager后验证您的sdk位置,并验证您是否安装了API 19